Once objects are grouped together, they are treated as if they were a sin-
gle object. You can move, resize and scale a group just as you do with an
individual object.

Figure 78

Changing the size
of a group.

The grouping of objects can be undone by selecting Ungroup from the
Arrange Imenu.
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Using the Clipboard

Before reading this section make sure you are familiar with the use of the
HyperLook clipboard (see “The System Properties” on page 3-31).

Copying and Pasting Objects

Selecting Copy from the Edit menu, or using the Copy key, copies the
selected objects to the clipboard.

Selecting Paste from the Edit menu, or using the Paste key, pastes
drawing objects from the clipboard into your drawing. You can use copy
and paste to move graphics from one graphics editor to another.

Duplicating Objects

To duplicate the selected objects use Duplicate from the Edit menu. An
exact copy of the selected object is added to the drawing a little below and

to the right of the original.
Figure 79 oy
object. //4;////
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move duplicate again

If you duplicate an object and then move the new object, HyperLook
remembers the offset. If you duplicate again the new (third) object has
an offset equal to that between the original and the first duplicate.

422 -
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Deleting Objects

To delete objects from a drawing, select them and hit the Delete key.
You can also select Clear from the Edit menu.

Select Cut from the Edit menu, or use the Cut key, to cut the selection
from the drawing to the clipboard.

Undo

Most editing operation can be undone. If you have made a mistake while
editing a drawing, simply select Undo from the Edit menu, or use the
Undo key, to undo the last change.
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Special Objects
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Figure 80

Creating a text
object.The object
is in edit mode.

Figure 81

The text after
reselecting it. It is
no longer in edit
mode.
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So far, you have learned how to edit objects such as rectangles and lines.
Some of the other objects have special features, which are discussed in
this section.

Text Objects

To add a text object, select the text tool from the tool pallet, and click on
the location where you want the text. An empty text object will be added.
To enter the text, just start typing.

While the object is selected and you're typing text, it will be displayed in
edit mode.
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The text will look rather rough while in edit mode. As soon as you
deselect it, it will be redisplayed in its normal state.

A Text Object

Text objects can have multiple lines of text separated by typing return. If
you want to edit an existing text object just select it and start typing.

The Text menu has four submenus. The Font menu changes the font,
the Style menu changes the font style, the Size menu changes the font
size, and the Align menu changes the alignment of multi-line text
objects.



The size and scaling of the font is adjusted when the object’s size is
changed. You can resize a text object just like any other object.

Figure 82

The text after
stretching it using
the marker points.

You can rotate text objects. All of the operations that you can apply to
other objects work with text objects too. )

Pie Objects

Pie objects let you create sliced pie shaped wedges. A pie object, when
selected, shows 2 extra marker points. You can drag them to change the

angular size of the pie slice. The exact angle of the slice is displayed near
the cursor while you are changing it.
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Rounded Corner Rectangles

A rounded corner rectangle also has an extra marker. It lets you change
the roundness of the corners. The rounding is restricted to the minimum

of the width and the height of the rectangle. The size of the rectangle’s
corners is displayed near the cursor while you are changing it.

Figure 84
A rounded corner
rectangle with the
extra marker
point.
Polygon and Spline Objects
AT The easiest way to draw a complex curve is with the freehand tool. When
DN it is active, dragging the mouse creates a polygonal path following the
%% mouse. The freehand tool is ideal for entering paths with smooth curves
and strange shapes.
(=} |
b
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Figure 85

A polygon created
with the freehand -

tool.

Figure 86

Editing a polygon
using the extra
marker point.

~ special Objects

You can also enter a polygon point by point. This is like editing line
objects. A polygon has a marker point for every point you enter, plus one
extra marker point. This extra point extends the polygon. Dragging the
extra marker adds a new point to the polygon.

If you double click the polygon tool (see “Creating Multiple Objects” on
page 4-12), the next mouse click will add a new point to the polygon,
instead of creating a new polygon. This is useful if you want to add a lot
of points.

If you want to add an extra point to every edge of the polygon, then use
Double Poly Points from the Special menu. After adding more and
more points you can use Red:uce Poly Points from the Special menu
to reduce the points to the minimum necessary.
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Figure 87

Doubling the

number of polygon

points.

Figure 88

A polygon and its

spline.
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Once you have created a polygon, you can change it to a spline (a smooth
curve). Select Flip Poly and Spline from the Special menu. Splines
can be turned back into ordinary polygons using the same menu. Splines
are edited in the same way as polygons.




Figure 89

An image loaded
into the editor.

- Smcxa Objects

Image Objects

You can add images to a drawing by selecting Import from the File
menu. The editor can import Sun rasterfiles, which often have a .img
extension (see “The Clipboard” on page 3-18, on how to use the OpenFile
dialog to enter an image file name). When the image is loaded, it is added
to the drawing in the center of the view.

You can also load images with other file formats. To load such an image
you must provide a filter to convert the image from its original format
into Sun rasterfile format. The name of the filter tells HyperLook what
extensions to expect on the image files.

The filter is called with the input file name as the first argument. It
should produce the raster file on the standard output.

For example, you might use a filter to convert tiff format images into
rasterfile format. To do this you create a file called tiff2img in a
resource directory (for example ~/stacks). This tells HyperLook that it
can convert files with a .tiff extension into Sun rasterfiles using the
filter. HyperLook will use the filter automatically every time you load a
.tiff file into the graphics editor.
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Figure 90

An Encapsulated
PostScript object.

4-30
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Suppose you have a filter called tiffras, located in the /usr/local direc-
tory. To install the filter use:

ln -s /usr/local/tiffras ~/stacks/tiff2img

This will enable you to load images with a .tif£f extension.

In general, to be able to use other extensions set up a filter in a resource
directory ext2img if “. ext” is the desired extension.

HyperLook provides the z2img filter which lets you load compressed
rasterfiles.

Encapsulated PostScript Objects

The editor is able to load Encapsulated PostScript files (also called EPS or
EPSF). EPS files usually start with the line:

% !PS—-Adobe-2.0 EPSF-1.0

To load an EPS file select Import from the File menu and select a file
with a .eps, .epsf or .ps extension.




Figure 91

Creating a triangle
by drawing lines.

When the file is loaded, it is drawn into an image and the image is dis-
played. This optimizes the time spent drawing it.

If you prefer the editor to draw the file directly onto the screen, make the
object transparent using the fill color tool (see “Selecting the Fill and Line
Color” on page 4-17). When the object is transparent, it takes longer to
draw onto the screen but it is displayed better at different magnifica-
tions.

Solid Objects

Sometimes you want to draw a shape that is not part of the standard set
of graphics objects. An example is a triangle.

The editor lets you to create new shapes by drawing the outline using
lines, arcs, rectangles, etc.

To create a triangle, first draw a triangle using three lines, then select all
three lines, and select Solid Group from the Special menu.

When creating solid objects from lines you must make sure that the lines
are properly connected.

The solid group can be ungrouped into its original components with the
Ungroup item of the Arrange menu.
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Interesting effects can be created with solid groups. It's possible to create
objects that have holes in them. Take a triangle, draw an oval over it,
select them both, and make a solid group out of it. The result is a triangle
with a hole in it!

Figure 92

Creating a triangle
with a hole in it.

Clipped Objects

The editor lets you draw an object though a stencil of any shape. This
technique is called clipping.

To create a clipped object, draw a shape over a drawing, select the shape
and the drawing, then choose Clipped Group from the Special menu.

Figure 93

Creating a clipped
group.
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The bounding box of the clipped object is as big as the shape to which
the drawing is clipped.

The clipped object can be returned to its original components using
Ungroup from the Arrange menu.
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The Graphics Editor Menus

e -

This section explains all the menus and their items. The main menu is
shown by holding down the right mouse button anywhere on the paper.

Open
Load a drawing (see “Loading Drawings” on page 4-6).

New
Start a new drawing, discarding the current one. You are asked for
confirmation.

import

Import a drawing, Encapsulated PostScript (see “Encapsulated
PostScript Objects” on page 4-30) or image (see “Image Objects” on
page 4-29).

Revert
Reload the drawing from its file, discarding any changes made to
the current drawing since it was last saved.

Save
Save as...

Save EPS...
Save the drawing (see “Saving Drawings” on page 4-6).

Print
Print the drawing (see “Printing Drawings” on page 4-7).
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Edit

Select All
Select all the objects in the drawing (see “Selecting Objects” on

page 4-9).

Undo
Undo the previous editing operation (see “Undo” on page 4-23).

Cut, Copy, Paste, Clear
Clipboard editing operations (see “Using the Clipboard” on
page 4-22). ’

Duplicate
Duplicate the currently selected objects. Repeated duplicates will
be offset by the same amount (see “Duplicating Objects” on

page 4-22).

Nudge Left

Nudge Right

Nudge Up

Nudge Down

Nudge the selected objects in the indicated direction. The distance

of the nudge is the grid size. The arrow keys are shortcuts to these
menu choices (see “Moving Objects” on page 4-13).

Text

Font

Set the font of the selected text objects (see “Text Objects” on
page 4-24 and “Changing the System Fonts” on page 3-31).

Style
Set the font style of the selected text objects. Options are Plain,
Bold, Italic or BoldItalic.
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Size
Set the size of the selected text objects. The text objects will be
resized to fit the new font height (see “Text Objects” on page 4-24).

Align
Change the alignment of the selected text objects. Alignment is only
significant if the text has multiple lines.

Grid

Change the current grid (see “Using the Grid” on page 4-15).

View

Center

Move the selected object into view. If no object is selected, then the
whole drawing is moved into view.

Zoom Normal

Zoom In

Zoom Out

Change the magnification (see “Zooming” on page 4-8).

Arrange

To Front
To Back

Change the front to back order of the selected objects (see “Front to
Back Order” on page 4-20).
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Group
Ungroup
Change the grouping of objects (see “Grouping” on page 4-20).

Align

Align Center

Align Left

Align Right

Align Top

Align Bottom

Align Vertical

Align Horizontal

Align Grid

Align multiple objects (see “Aligning Objects” on page 4-16).

Special

Solid Group
Create a new shape by combining multiple objects (see “Clipped
Objects” on page 4-32).

Clipped Group
Clip a part of an object (see “Clipped Objects” on page 4-32).

Flip Poly and Spline
Change a polygon into a spline and vice versa (see “Polygon and
Spline Objects” on page 4-26).

Double Poly Points

Reduce Poly Points

Change the number of polygon points (see “Polygon and Spline
Objects” on page 4-26).
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Flip to Normal
Remove rotation and flipping from an object (see “Rotating Objects”
on page 4-14).

Flip Left-Right
Flip Top-Bottom
Flip the selected objects around their vertical or horizontal axis.

Scale 200%

Scale 50%

Make objects larger and smaller (see “Changing the Size of Objects”
on page 4-13).
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Figure 94

Designing your
own stacks.

Editing Stacks

Every editable HyperLook stack can be in one of two modes!. The first is
called browse mode. In this mode you can use the stack, move from card
to card, etc. The other mode is edit mode. It lets you change the stack
and its objects.

This chapter explains how to create and edit stacks and objects. How to
create and use cards and backgrounds is also described in detail (see
“Cards and BackGrounds” on page 5-24).

Chapter 6, “Object Properties” explains how to modify HyperLook
objects. Chapter 7, “Scripting” explains how to program components and
stacks.

Designing Your Own Stack

Before going into details, it is useful to explain the process by which you
create and design stacks.

Normally you will start by creating a new stack from scratch. You then
switch the stack into edit mode and add, edit and delete objects, cards
and backgrounds.

When you are happy with your stack, you switch it into browse mode and
test it.

When you have finished editing the stack, save it in a file. The stack can
be reloaded at any time.

Now you can connect a C program to your stack. See Chapter 8, “Client
Programming” on how to communicate with stacks from C programs.

1. Some applications use non-editable stacks.
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Figure 95

HyperLook cur-
SOrs.

At any point in the design process, you can test the stack, save it, or
revert to a previously saved version. This gives you the confidence to try
things out!

Edit Mode

In edit mode you can modify the stack, its cards, backgrounds, and com-
ponents.

To get to edit mode you can use the stack menu (see “Using Menus” on
page 3-5). You will often read instructions like “select Save from the
Stack menu”. This really means “select the Save option from the Stack
sub menu of the stack menu”.

Select Edit Mode from the stack’s Edit menu to switch to edit mode. To
leave edit mode select Browse Mode from the Edit menu. A quick way to
enter and exit edit mode is by typing Meta-E.

In edit mode, the objects of a stack do not respond to user input. The
stack editor intercepts all user interaction until the stack is in browse
mode again.

It is not possible to move a stack when it is in edit mode. To move the
stack, first return to browse mode (see “Moving Stacks” on page 3-9).

The fact that a stack is in edit mode is reflected by a change in the cursor.
Usually the cursor in browse mode is a little hand, in edit mode the cur-
sor is usually a bull's eye'.

dy o # X +

browse cursor edit cursors

1. You will notice that in edit mode the cursor changes depending on its position.
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The Stack Menu in Edit Mode

A stack in edit mode has an extended menu. There are 3 different menus
which are active depending on the number of selected objects:

* no object selected

* one object selected

e multiple objects selected

Each of the menus is different. The Look menu is always available.

Most menu functions apply to either the selected object or objects, the
current card, the current background or the stack itself.

If you want to see at a glance what all the menus do, read “Edit Mode
Menus” on page 5-36. Otherwise read on and you'll find out about how
to edit stacks, encountering options on the stack menu along the way.




Editing and Saving Stacks

Figure 96

The new button in
the OpenStack.

Figure 97

Creating a copy of
the Untitled stack.

This section explains how to create new stacks and how to save them
when you have finished editing them.

Creating a New Stack

To create a new stack, press the Open button in the system stack. This
will show the OpenStack stack (see “Opening Stacks” on page 3-8).

The New button

T

Now click on the New button and a new untitled stack will appear.

The standard Untitled stack has some useful components which you can
remove if you don’t need them.

If you enter the name of an existing stack before hitting the New button
you will create a copy of the stack. The new stack is given a name that
differs from the original.

Another way to create a new stack is to save an existing stack using a
new name (see “Saving Stacks” on page 5-6). You can still reload the orig-
inal stack!
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Figure 98

The SaveStack
dialog.

5-6

Saving Stacks

After you have made changes to your stack, you can save the stack by
selecting Save from the Stack menu. The stack is saved to the file from
which is was loaded.

If the stack is untitled, or if you select Save As. .. from the Stack menu,
a dialog is shown which lets you choose a new name and a new directory
for the stack.

stack name

directory

Type the name of the stack in the Name field and click on the Save button.
The stack will be saved to the directory which is listed below the name.

The “?” pulldown lets you select a different user resource directory. Use
the resource manager to add new resource directories (See “The
Resource Manager” on page 3-23).

Reverting Stacks

You can revert a stack to the previously saved version by selecting
Revert from the Stack menu. You cannot revert a stack if it has not yet
been saved.




Figure 99

Are you sure you
want to throw
away changes?.

Editing and Saving Stacks

Throw Away Changes?

If you try to zap or revert a stack which has been modified, the changes
to the stack will be lost. An attempt to do this will show a dialog asking
whether you really want to throw away the changes.

If you really want to throw away the changes, press the Yes button. If
you have changed your mind and want to save the changes, press No.

Printing Cards

The current card of the stack is printed by selecting Print Card from
the Card menu. See “Specifying a Printer” on page 3-32 if you want to
change the printer.
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Figure 100

The properties ofa
stack.

5-8

Stack Properties

You can change the properties of a stack by selecting Stack Info from
the Stack menu to show the properties window of a stack.

stack name

7

After changing the properties of the stack press the Apply button. You
can undo the changes made by pressing Reset. When you have finished,
press Done.

Don't worry about the Script and Help buttons as they are explained
later.
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Stack Properties Explained

The stack name field shows the name of the stack. The File field shows
the file from which the stack was loaded (if any).

The Client field shows the name and process id of the client which is
connected to the stack. If no client is connected, [?] is shown.

The Objects field shows some information on the objects, cards and
backgrounds of the stack (these are explained later).

The AutoZap numeric field lets you specify the time in minutes between
the stack being zapped from the screen and really being deleted from
memory. See also “The Stack Manager” on page 3-22. If this field is left
empty, the stack is not automatically deleted from memory after zapping
it (it remains in the trash indefinitely).

The MinSize numeric fields let you specify the minimum width and
height of the stack. These fields are ignored if the stack is not resizable
(see “Making a Stack Resizable” on page 5-11 on how to create resizable
stacks).

The SaveBehind checkbox determines whether the screen behind the
stack is saved to allow for fast drawing when the stack is hidden. This
feature is useful for stacks which are visible for a short time only, but
you may want to disable this feature if you are short of memory.

The Retained checkbox determines whether the stack’s content is
retained to allow for fast redrawing. This feature is useful when drawing
the stack takes a long time. Retained stacks take up a lot of memory!

The Fixed position checkbox lets you specify whether the stack can
be moved around on the screen or not.

The Resizable checkbox indicates whether the stack can be resized or
not. See “Making a Stack Resizable” on page 5-11 on how to create resiz-
able stacks.
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Figure 101

Defining a stack
shape for the
Notepad stack.

5-10
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Designing the Shape of a Stack

The graphics editor in the stack properties window lets you draw the
shape of the stack. The drawing you enter here must consist of at least
one graphical object, for example a circle or a rectangle.

The shape of the stack window is defined by the back most graphical
object. All the graphics are drawn into that shape.

For example, to create a window with rounded corners you can draw a
rounded corner rectangle. You can also create more complex shapes. The
Notepad stack is a good example of a stack with a complex shape.

First the ring binder shape was created by linking a set of lines and arcs
together into a solid object (see “Solid Objects” on page 4-31). This is
then used as the shape of the stack.

Next the rings are drawn on top of the stack shape. The stack shape is
now ready. You have created a stack shaped like a ring-binder simply by
drawing!

Sometimes the outline of the stack is not completely visible. This is
because the outline is clipped by the stack shape. Avoid using complex
curves as a stack shape for this reason.

Make sure that the shape of the stack is completely filled with graphics.
If parts of the stack’s interior are not filled, bits of the things behind the
stack may not be painted and show through.



Figure 102

A resize corner
added to the
Untitled stack.

 Editing and

Making a Stack Resizable

By default stacks are not resizable. To make a stack resizable, you must
first switch on the Resizable property of the stack (see “Stack Properties
Explained” on page 5-9).

Now you have to add some resize corners to the stack. The ButtonIdeas
stack contains a few resize corners you can use. Install all the compo-
nents of the ButtonIdeas stack into the New menu by following the
directions in “Using the Object Warehouse” on page 5-13.

k_reslze corner

When you resize the stack, the stack shape changes. This usually works
best for simple stack shapes such as rectangles. Any graphics on a resiz-
able stack should be encapsulated in buttons (see “Drawing Buttons” on
page 6-10), otherwise they may be resized incorrectly.

For each object in the stack, you should set its glue to make sure that it
is moved to its appropriate location after the stack has been reshaped.
The glue of an object is set from the object’'s property stack (see “Glue
Property” on page 6-5).
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Creating New Objects

Figure 103

Adding a button to
the Untitled stack.

5-12

Once you have created your own stack, you can create new objects by
selecting an object type from the sub menus of the New menu.

These menus gives you a choice of HyperLook objects. You can, for exam-
ple, create a new push button object by selecting Button from the
System sub menu.

The newly created object is automatically selected. See “Selecting
Objects” on page 5-15 for how to select objects.




Creating New Objects

Using the Object Warehouse

HyperLook provides an object warehouse. To see the warehouse select
Show Warehouse from the New menu.

Figure 104

The object Ware-
house.

You can copy objects from the Warehouse stack or you can install the
Warehouse menu by pressing the Install button.

After pressing the Install button you will find that the New menu has a
new sub menu called Warehouse. This sub menu contains a list of the
objects on the Warehouse stack. Selecting an object from this menu cre-
ates a new copy of the object from the warehouse.

5-13



Hym Editing Stacks

Another source of objects is the ButtonIdeas stack. Use the OpenStack
dialog (see “Opening Stacks” on page 3-8) to open the ButtonIdeas
stack and press Install.

Figure 105

The Buttonldeas
stack.

Again you'll see that the New menu has a new submenu -called
ButtonIdeas. In particular, the ButtonIdeas submenu contains resize
corners that may be used when creating a resizable stack.
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Editing Objects

Bl X

Select
cursor +

Figure 106
A selected object.

Figure 107

Selecting multiple
_objects.

This section explains how to edit objects on a stack.

A grid is active while editing objects. The grid is not visible but it controls
how finely you can adjust the position of objects on the stack. See “Stack
Editor Properties” on page 5-33 to see how to configure the stack editor
to use a different grid size.

Selecting Objects

A stack can contain lots of objects. To edit an object you must first select
it. A double rectangle with resize corners is drawn around the object to
show that it is selected.

election rectangle

esize corner

The easiest way to select an object is simply to click on it. If several
objects are overlapping, click again to select the object below.

You can select more than one object at a time. Hold down the mouse and
drag a rectangle around the center points of the objects that you want to
select. While you hold down the mouse button all object rectangles and

center points are highlighted.

during selection after selection
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Move
cursor

Figure 108
Moving an object.

5-16

Clicking on an object with the middle mouse button adds or subtracts it
from the selection. It is an easy way to select several objects which are
far apart.

Moving Objects

An object (or a set of objects) can be moved to a new position by holding
down the mouse inside the object’s boundary. While holding the mouse
down, drag the object to the desired position and release the mouse.

You can move more than one object at the same time in the same way.

See also “Position and Size Properties” on page 6-6 on how to change the
position of an object from the object properties stack.

You can also move objects using the arrow keys on the right hand side
of keyboard. The selected objects are nudged in the appropriate direction
by one grid measure (see “Stack Editor Properties” on page 5-33 on how

to change the grid).




Size
cursor

Figure 109

Changing the size
of an object.

Sizing Objects

To change the size of an object, hold the mouse down in one of the resize
corners of a selected object. While holding down the mouse, change the
size by dragging. The object is redrawn at its new size when you release
the mouse.

Some objects have a fixed size which does not depend on the object’s
bounding rectangle. Horizontal scrollbars, for example, have a fixed
width.

Constrained Editing

When you resize or move objects it is often useful to constrain the move-
ment horizontally or vertically. Hold down the Control key while sizing or
moving objects for constrained editing.

Another constraint is activated when holding down the Meta key while
moving or sizing an object. The mouse will move in tiptoe mode. The
movements of the mouse are slowed down to give you more control.
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Figure 110

Aligning objects
using Align
Left.

5-18

Aligning Objects

When more than one object is selected, it is possible to arrange them rel-
ative to each other.

before after

Objects are aligned by selecting from the Objects menu:

e Align Center - Center around the same point.

e Align Left - Left side against a vertical line.

* Align Right - Right side against a vertical line.

°* Align Top - Top side against a horizontal line.

* Align Bottom - Bottom side against a horizontal line.
¢ Align Vertical - Center along a vertical line.

°* Align Horizontal - Center along a horizontal line.

The position of the objects is dictated by the first object in the selection.
It remains stationary while the other objects are repositioned.

Front to Back Order

The objects of a stack can overlap. Usually this causes no problems.
Problems may occur when an object underneath another object redraws
itself. Overlapping objects will be affected.




Figure 111

Sending some
static text to the
back.

Editing ijects

This means that it is only safe to have static objects (such as graphics
and static text) overlapped by other objects. It is not safe to have dynamic
objects (like editable text) below other objects, because it may cause the
stack to be updated incorrectly.

To bring an object to the front, select To Front from the Object menu.
To send an object to the back, select To Back from the Object menu.
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Using the Clipboard

Before reading this section you should be familiar with the use of the
clipboard (see “The Clipboard” on page 3-18).

Copying and Pasting Objects

Objects can be copied to the clipboard just like text and graphics. Select
one or more objects and use Copy from the Edit menu, or use the Copy
key.

Figure 112

A button pasted
into the stack.

You can now paste the object into another stack by selecting Paste from
the Edit menu, or use the Paste key. Copying and pasting objects is
useful if you want to use objects from other stacks.

In the example above the Draw button from the system stack was copied
from the system stack and pasted into an untitled stack!.

1. It still produces a drawing tool when pressed!
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Figure 113

Duplicating an
object.

Using the Clipboard

Duplicating Objects

To create a duplicate of an object, select the original and use Duplicate
from the Edit menu.

before

Duplicating an object creates an identical copy of the original. It is offset
by a few pixels. Duplication of objects is useful when you want to create
a row of buttons each of the same size.

Deleting Objects

To delete an object simply hit the Delete key while the object is selected.
You can also select Clear from the Edit menu.

Selecting Cut from the Edit menu, or using the Cut key, copies the
object to the clipboard before deleting it.
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Figure 114

Copying proper-
ties.

Figure 115

Pasting a drawing
into a stack.
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Copying and Pasting Object Properties

Often you want to copy the style of an object to other objects. It is possi-
ble to copy an object’s properties to the clipboard. Make sure that the
object of the desired style is selected and select Copy Object Props from
the Edit menu.

copy properties now select and paste the result

Now select one or more other objects and select Paste from the Edit
menu. The properties of the selected object will be set to be identical to

the original.

Pasting Text and Graphics

You can paste text directly into a stack when the stack is in edit mode.
The text is inserted either as a field object (if it is a single line of text) or
as a text object (if it contains newline characters).

Pasting a drawing into a stack creates a button of the right size to hold
the drawing (see “Drawing Buttons” on page 6-10).




Using the Clipboard

Copy as Drawing

You can copy an object as a drawing to the clipboard by selecting the
object and using Copy Object as Drawing from the Edit menu. An
Encapsulated PostScript drawing is generated by drawing the object and
capturing the PostScript instructions that are executed.

Figure 116

A stack, after
being copied as a
drawing, really is
a drawing!

You can also copy a whole stack as a drawing. When no object is selected,
select Copy Stack as Drawing from the Edit menu. Most illustrations
in this manual were created this way (apart from some screen snap
shots).

Due its complex nature, the copy as drawing operation may take some
time!. Keep an eye on the SystemStatus stack (see “The SystemStatus
Stack” on page 2-6). It will tell you when the drawing is ready. Then you
can paste it into a graphics editor.

1. It can take from a few seconds to a full minute for complex stacks.
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Cards and BackGrounds

Each stack can have multiple cards and each card has a background
which it can share with other cards. See “Using Stacks” on page 3-7 to
see how to move between cards in a stack. The stack, background and
cards are arranged in a tree structure as shown in Figure 117.

You can see that each layout is made up of objects from the card, back-
ground and stack layers. The word layout is normally dropped, because
there is a one-to-one relationship between layouts and cards. Trace a
path back from the layout to the stack and you will be able to work out
how each layout is drawn.

thure 117 Stack
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grounds are i
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Figure 118

The properties ofa
card.

Cards and BackGrounds

The objects of a stack can be on one of three layers:

1. Stack layer. Objects on this layer appear on every card. It is often
used to hold components such as resize corners.

2. Background layer. Objects on this layer appear only if the current
card has this background. Multiple cards can share the same back-
ground. This layer is therefore used to hold objects which should
appear on a set of cards.

3. Card layer. Objects on this layer appear only if the card is visible.

Objects on the stack layer always appear behind objects from the back-

ground or card layer. Objects from the background layer always appear

behind objects from the card layer but in front of objects from the stack
layer. See “Generic Properties” on page 6-3 on how to specify the layer of
an object.

Adding and Deleting Cards

To add a card simply select New Card from the Card menu. This adds a
card just after the current card.

The new card will have the same background as the current card. This
means that the stack and background objects of the current card will
appear on the new card too. The card itself will be empty.

To delete the current card select Delete card from the Card menu. A
stack must contain at least one card.

Card Properties

Selecting Card Info from the Card menu show the card properties stack.
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After changing the properties of the card, press the Apply button. You
can undo the changes made to the properties by pressing Reset. When
you are finished press Done.

Don't worry about the Seript and Help buttons they are explained later.

Card Properties Explained

The Name field lets you specify the name of the card.

The BackGround pulldown lets you select either New BackGround to give
the card a completely new background, or the-name of an already exist-
ing background. See “Using BackGrounds” later in this section on how
backgrounds are used.

Copying Cards to the Clipboard

You can copy a card and its contents to the clipboard by selecting Copy
Card from the edit menu.

Pasting the card into a stack (when in edit mode) causes the card to be
added after the current card of the stack. The card will have the same
background as the current card.

Using BackGrounds

Backgrounds are useful if you want some objects to appear on a group
of cards. Figure 117 on page 5-24 shows an example of an application
where the next and previous buttons (the arrows) appear on every card
of the stack except the first one.



Cards and BackGrounds

This arrangement is achieved as follows:

1. Create a new stack.
2. Edit the first card of the stack.

3. Add a new card to the stack, then go to the new card and give the
new card a new background (see “Card Properties” explained ear-
lier).

4. Create next and previous buttons and set their layer property to
BackGround (see “Generic Properties” on page 6-3).

5. Add two new cards to the stack. They will both use the background
with the previous and next buttons.

The advantage of using backgrounds is that the objects on the back-
ground are shared between cards!. If you make changes to an object on
a background these will affect all the cards that share the background?.

You can assign a new background to the current card by selecting New
Background from the Card menu. A new background can also be
assigned from the card properties (see “Card Properties” earlier in this
section).

BackGround Properties

Selecting Background Info from the Card menu shows the properties
of the current background.

Figure 119

The properties ofa
background.

The only property that you can change for a BackGround is the name.
Enter the name in the Name field.

1. This saves memory!
2. This saves time!
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After changing the properties of the background, press the Apply button.
You can undo the changes made to the properties by pressing Reset.
When you are finished press Done.

Don't worry about the Script and Help buttons as they are explained
later.




- Defining Help

Defining Help

Figure 120

Getting help text
on an object.

You can add help text to any HyperLook object. This text is shown when
the Help key is pressed while the mouse is over the object.

f&k is a drawing button. Use the left mouse button.

The section “Using Help” on page 3-3 describes how to get help on
HyperLook objects while you are in browse mode. In this section, you'll
find out how to change the help text for HyperLook objects. You do this
in edit mode, and you don't need to do any programming!

5-29



l-fyw Editing Stacks

Editing Help Text

When you press the Help key in edit mode, a text editor is shown which
lets you edit the help text of the selected object.

Figure 121 Oigwfﬂeipfw

Editing the help Sutton(#PravicusButton) on Stack(Untitied#1) .

text of an object. This is a previous button. it takes you to the pmvlous card of O
i the stack. Use the left mouse button.

After editing the help text, press the Apply button. Press Reset to undo
the changes that you have made. When you have finished editing the
help text, press Done.

You can also edit the help text editor by pressing the Help button on the
property stack of an object, card, background or stack.

Looking for Help

Every object, including stacks, cards and backgrounds, can have help
text. When the Help key is pressed, the text is located in the following
order:

The object under the cursor
The current card

The current background
The stack

L
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If no help is found, then some generic help is shown for the object or the
current card. If help text is found at more than one level, the first help
.-found is shown. ,

The way help text is located lets you specify generic help for a stack. If
no help text is defined for an object, the current card and the current
background, thern the stack’s help text is shown. It also lets you define
help text per card or per background.

To edit the help text of a stack, background or card, press Help in the
relevant property window. It is really very easy to add help to your appli-
cation. '

A g
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Black and White Stacks

5-32

HyperLook stacks that are designed for a color screen may look bad on
black and white screens. This is because colors with different hues can
have equal intensities. Also, the stipple patterns which are used to rep-
resent colors of varying intensities can look bad on low resolution
screens.

You can design black and white versions of your stacks, and save them
in a sub directory of your resource directory called mono. The resource
manager will add the mono directory to the resource directory list only
when HyperLook is running on a black and white screen.

See “The Resource Manager” on page 3-23, which explains how to add
and remove resource directories from the resource directory list (see also
hlpath(1l) on page C-5).

You don't need to worry about the mono directory if you design your
application for black and white screens only.




