 Using Stacks

The “?” pulldown menu in the OpenStack dialog lists recently opened
stacks. If you select a stack from this menu it will be opened (use the left
mouse button). Stacks that have been changed are marked with a “*”
character.

While typing the stack name you can type Tab to complete the name of
the stack if it has been recently loaded.

Press Cancel to cancel if you don’t want to open a stack after all. Press
New if you want to create a completely new stack (see “Creating a New
Stack” on page 5-5).

So now you can see how easy it is to explore HyperLook. Once you know
the name of a system stack you can open it, exactly like a stack of your
owm.

The Stack Menu

Every stack has a pop up stack menu. This menu provides some basic
functions to manipulate the stack. Figure 24 on page 3-5 shows the
stack menu.

One word of warning, some objects have their own menu which is shown
when holding down the right mouse button inside them. To show the
stack menu make sure that you hold down the mouse over an empty
region of the stack.

Moving Stacks

Most stacks can be moved to a new position on the screen by holding
down the mouse button and dragging the stack to a new position. Go
back and reread “Use of the Mouse” on page 3-4 if you are having trouble
with the mouse buttons.
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Figure 29
Moving a stack.

Figure 30

Bringing a stack
to the front.
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To move a stack, hold down the mouse in an unoccupied area of the
stack or in a non-active object like the title of the stack. Clicking in an
active object usually activates the object, instead of moving the stack.

NN

Some stacks can't be moved, so attempts to move them are ignored. Most
of HyperLook's dialogs and property stacks can’t be moved.

Bringing Stacks to the Front

In a multi-window environment, stacks and window can cover each
other, so sometimes you need to change their front to back ordering.

To bring a stack to the front, simply click in an unoccupied area of the
stack. You can also bring it to the front, or send it to the back by pressing
the Front key on the keyboard, while the mouse is anywhere over the
stack.

When you press the Front key and, the stack is already at the front, it
will be sent to the back instead!



Figure 31
Iconifying a stack.

Figure 32

A close button and
resize corner.

-;;giingf-:§t§€k$

Iconifying Stacks

Stacks can be iconified. A stack icon is a miniature version of the stack,
displayed at the bottom of the screen. An iconified stack does not accept
any user input until it is de-iconified (opened).

To iconify a stack, press the Open button on the keyboard. This might
seem odd to you at first, but you'll soon get used to it. To open an icon
you also use the Open button or you can double click on the icon.

Resize corner

Close button

Some stacks also have a close button. When you click on it, it iconifies
the stack.

Resizing Stacks

Some stacks, such as the graphics editor, have resize corners. The resize
corners lets you change the size of the stack.

Hold down the mouse in one of the resize corners, and drag it until the
stack has the desired size.
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Redrawing Stacks

Sometimes a stack needs redrawing. The stack can be redrawn by press-
ing the Again key on the keyboard while the mouse is over the stack.

Zapping Stacks

After finishing with a stack, you can zap it from the screen. Select zap
from the stack menu. Zapping clears the stack and the icon from the
screen and from memory as well. Actually, it usually takes a few minutes
before the stack is really removed from memory (see “The Stack Man-
ager” on page 3-22 on how to use the stack manager).
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Using HyperLook Components

Figure 33
Pressing a button.

Figure 34

Examples of
checkbox.

This section will briefly discuss how to use the most common HyperLook
components. Some components such as text and text fields have key-
board accelerators which you will find useful.

Using Buttons

Buttons are very easy to use. Hold the mouse down inside the button and
the button will highlight. Releasing the mouse while the button is high-

lighted executes its action.

RButton

depressed button

xrnn

If you change your mind while holding down the mouse, move the mouse
out of the button’s area until it is no longer highlighted and release. Then
the action is not executed.

Using Checkboxes

A checkbox is another type of button. It can be on or off. If the checkbox
is crossed it means that it is on.

[ Locked -« Not locked

/Locked
™ Locked

To change the state of the checkbox, click the mouse inside it.

3-13



Figure 35

An active horizon-
tal scrollbar.

Figure 36

Atext objectand a
field object.
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Using Scrollbars

Scrollbars are used in text objects, graphics editors, lists etc. A scroll bar
is very simple, it lets you scroll text or graphics in a horizontal or vertical
direction.

W .S

i : .

nudge scroll nudge
left anywhere right

jump jump
left right

Horizontal and vertical scrollbars behave in the same way. The drag box
of a scrollbar (the little box in the middle) lets you scroll to any position.
Hold the mouse down in the drag box, drag it to the desired location and
release.

Editing Text

Text objects are divided into single line text objects called Fields and
multi line text objects simply called Text.

Text objects can haye a—
vertical .t‘o the
right of the text. To select

some text hold down the Text object
mouse in the text and

selected text

Field object
&an havelscroll buttons w_> <€*— J

e scroll button

ch or

Text objects can have a vertical scrollbar to the right of the text. Fields
can have scroll buttons when the string which you are editing is longer
than the field itself.




To select some text hold the mouse down at the beginning and, while
holding the mouse down, drag the mouse to the end of the selection and
release. The selected text will be highlighted.

See section “The System Properties” on page 3-31 on how to use the clip-
board when editing text.

Text objects‘ accept keyboard commands. These commands are listed
below. Commands that assume multiple lines of text do not work for
Field objects.

Control-A -- go to the beginning of the line
Control-B -- go to the previous character
Control-E -- g@ to the end of the line.. ...
Control-F -- go to the next character
Control-G -- go to the end of the next word
Control-N -- go to the next line

Control-P -- go to the previous line
Control-Q -- go one page up

Control-R -- go to the beginning of the previous word
Control-S -- go to the beginning of the text
Contxol-V -- go down a page

Control-Z -- go to the end of the text

You can also use the arrow keys (R8, R10, R12 and R14) to move around
in the text.

Control-C -- delete the current line

Control-D -- delete the next character
Control-K -- delete until the end of the line
Control-O -- split the current line

Control-U -- delete until the beginning of the line
Control-W -- delete the previous word
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Figure 37

A scrolling list font
selector.
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¢ Control-L -- redraw the text

¢ Control-T -- go to the next text field (see also “Controlling the Input
Focus” on page 6-13)

e Esc -- execute the action of the text

Scrolling Lists

Scrolling lists let you select an item from a list. On the right hand side
they have a scrollbar which lets you scroll through the list.

Times
Helvetica
Courier

Symbol
AvantGarde
Bembo

Bookman

You can use the arrow keys on the keyboard (R8 and R14) to move the
selection up or down. Another useful way of selecting an item in the list
is by typing the first letter of the item. If there are more items which start
with the same letter, then type the letter again to select the next one.

Some scrolling lists can have multiple items selected (nonexclusive).
Others can have only one item selected at a time (exclusive). Double
clicking on a selected item usually executes the action of the list.




Figure 38

Selecting an item
from a PullDown
button.

Figure 39

Selecting a color
using a
ColorSelect object.

Using HyperLook Components

Pulldown Buttons

Pulldown buttons are buttons which have their own pulldown menu.
Holding down the mouse in the button shows the menu. You can then
drag the mouse over the desired item and release it.

The menu of a pulldown button can also have pull right sub-menus. See
“Using Menus” on page 3-5.

Color Selectors

A ColorSelect item lets you select a color from the color pallet. Most prop-
erty stacks contain ColorSelect items (see Chapter 6, “Object
Properties”).

selected
Stroke color: . color

Fill color:

Holding down the mouse in the ColorSelect button shows pops up a
menu containing the same set of colors as the ColorPallet. Drag the
mouse to the desired color and release.

See “The Color Pallet” on page 3-20 to find out how to change the colors
on color pallet.
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The Clipboard

Figure 40

The Clipboard
stack.

Figure 41

The Clipboard
stack containing a
drawing.

3-18

HyperLook uses a Clipboard to move data between windows or applica-
tions. You can show the Clipboard by selecting Clipboard from the
Tools pulldown in the system stack.

It’'s possible to cut or copy some text onto the clipboard, and then paste
it from the clipboard into another application.

Use the OpenWindows function keys labelled Cut, Copy, Paste for clip-
board operations (see “The OpenWindows Function Keys” on page 3-35).

The HyperLook clipboard can hold several types of data. Data types sup-
ported by the HyperLook system include text, drawings, HyperLook
components, etc.

Artwork, in the form of drawings, can be copied from one graphics editor
to another (see Chapter 4, “Graphics Editing”). While the drawing is on
the clipboard it will be displayed in the window.

The Clipboard stack has 16 pages. Each time you copy some data onto
the Clipboard it is put onto the next page. When all pages are full, the
first page will be used again and any data it previously contained before
is overwritten.




The Clipboard

You can use the Pgbn and PgUp keys on the keyboard to change pages in
the Clipboard. Select the page containing the data you want, the paste it
into your application.

This makes it easy to copy and paste multiple objects from one applica-
tion into another. First copy all the objects from the original application,
then paste them from the clipboard into the destination. This avoids
unnecessary switching between applications or stacks.
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The Color Pallet

Figure 42

The ColorPallet
stack.

Figure 43

The pallet of col-
ors.

3-20

HyperLook graphics get their colors from a color pallet which you can
change using the ColorPallet stack. You can show the ColorPallet stack
by selecting ColorPallet from the Tools pulldown in the system stack.

Selected color

red slider
green slider

blue slider

The set of colors that you choose the ColorPallet is used in all the
ColorSelect buttons.

On the right the red, green and blue sliders indicate the proportions of
red, green and blue in the selected color. The selected color has a little
rectangle around it.

The values of the red, green and blue sliders range from O to 1 where O
means the minimum intensity and 1 means maximum intensity.

transparent
white

6" black system grays (first row)

EEENRE e 0 system colors (second row)
BE /7 EEENE e

B HEEEEREEEE 1> user colors (bottom 2 rows)
CEZ7ANIRENE R EER

A bright red color is 1.0 for red and 0.0 for green and blue. A pink color
is 1.0 red, 0.7 green and 0.7 blue.

The top two rows of the pallet are system colors. You can modify only the
user colors (the bottom two rows). Select a user color and change the
color sliders to the desired value.




The quality of the colors in the color pallet depends on how you start
OpenWindows. The best results are achieved when OpenWindows is
started with the -cubesize large option (see “HyperLook on Color
Screens” on page 2-11).

3-21



iUsing Hyperiook

The Stack Manager

Figure 44

The StackMgr
stack.

3-22

The StackMgr stack is shown by selecting StackMgr from the Tools pull-
down in the system stack. The stack shows two lists, on the left is a list
of all the stacks that are currently loaded into the system, on the right is
a list of all the stacks in the trash.

stacks
loaded

time before

When you zap a stack from the screen it is not immediately deleted from
memory. It is kept in memory for a preset time which can vary per stack.
When this time expires the stack is really zapped from memory.

Stacks are kept in memory for a while because reloading is then much
faster. Some stacks are used frequently and loading them from disk each
time would be slow.

The remaining time that a stack has to live is listed in the list on the left.
This list is called the trash because stacks can be deleted from it without
further notice. You may zap a stack from memory before the official time
is expired by selecting it in the list and then pressing the Really 2zap
button. You might want to do this to free up some memory for other
applications.




- The Resource Manager

The Resource Manager

HyperLook keeps a lot of your data in files on disk. The resource manag-
er's job is to locate these files. Files containing data such as stacks,
drawings, images, sounds etc. are called resources. The resource manag-
er’s task is to locate these resource files.

To show the ResourceMgr stack select ResourceMgr from the Tools
menu in the system stack.

The resource manager maintains a list of directories which are searched
when a resource is needed. For example the stacks directory in your
home directory is part of this list. It is used to store your own stacks.

Figure 45

The ResourceMgr
stack.

user
directories

user
resource
files

User Resources

The ResourceMgr stack contains two lists. The top one is a list of the user
resource directories. The bottom list is a list of resource files in the
selected resource directory.
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Select the appropriate directory in the top list to examine the files in a
resource directory. The resource files are then displayed in the bottom
list. You can double click on a resource file to open it.

Adding Resource Directories

To access resources from other directories you must add the directory to
the resource directory list. Press the Add Directory button and select
the appropriate directory using the dialog (see “Selecting Directories” on
page 3-30).

You can also use the hlpath program to add to the resource list. Type:
hlpath /usr/src/video/rsrc

in a Unix shell to add a directory to the list. Once the directory is added,
you can access its resource files.

Removing Resource Directories

A resource directory can be removed from the resource directories list by
selecting it and pressing the Remove Directory button.

Only remove resource directories when you are sure that no application
or stack needs it. If you remove a directory which is still needed, you may
get unexpected PostScript errors.

Application and System Resources

Pressing Other Resources shows the application and system resource
directories. You cannot change this list, only applications can.

When an application is started, it usually adds its own resource directory
to this list.



Figure 46

Application and
system resources.

You can view application resource files or system resource files by select-
ing the resource directory.

To get back to the list of user resources press User Resources.

Locating a Resource

The HyperLook system locates resources by searching the resource
directories in the following order (each list by itself is searched from top
to bottom).

1. user resource directories
2. application resource directories
3. system resource directories

If a resource file occurs in more than one resource directory, the first
occurrence is used. This means that user resources can override
resources in application or system directories.
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Press Locate Resource to find out exactly where a resource is located.
After pressing the button, enter the name of the resource file and press
Search. This searches for the resource.

Figure 47

Locating a
resource file.

If the resource is found, its file name is shown as well as a list of any
other file names matching that resource.

Press User Resources to get back to the user resources list.
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Handling Files

Figure 48

The OpenFile
dialog.

HyperLook provides file dialogs which are used by applications such as
the graphics editor to open and save files.

Each dialog is a simple directory browser, which lets you select the
appropriate directory, to open or save your file.

«— current directory

¢ file name
-a—— file list

The HyperDraw graphics editor uses the OpenFile dialog, to open draw-
ing files (see “Loading Drawings” on page 4-6).

When the dialog appears, it displays the message “reading directory”
while it reads the directory. When it's done reading, the files are dis-
played alphabetically.

If you want to cancel the whole operation, press the Cancel button.

Changing Directories
In the file list, directories are displayed ending in “/”.

The easiest way to change to a new directory is to type its name into the
File field, and type return. Either enter a full path name, or a path name
relative to the current directory.
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Another way to change to a new directory is to double click on the name
of the directory in the file name list. The new directory will be opened and
the new list of files displayed.

You can also select a recently used directory from a pull down. Just press
the left mouse button down over the “?” button, and select a directory
name from the list.

To go up a level in the directory tree, select the “../” directory or press
the Up button.

Opening Files

To open a file, simply double click on the file you want. Use the scrollbar
to scroll the list, if it is not visible.

You can also type the file name into the File field. Once you have
entered the file name, type return or press the Open button.

Sometimes the file name must have a particular extension. If you try to
open a file with the wrong extension, a message will be displayed to show
you the legal extensions, for example: “Extension must be .draw”.

Other error messages are displayed in the message field. For example, a
“cannot read file” message will be displayed when you don’'t have read
permission for the file.




Saving Files

To save a file the SaveFile dialog is used. This dialog is similar to the
OpenFile dialog.

Figure 49

The SaveFile
dialog.

The graphics editor uses the SaveFile dialog, to save drawings (see “Sav-
ing Drawings” on page 4-6).

Select a directory and enter a file name in the same way as the OpenFile
dialog. Once you have entered the correct file name in the file field, type
return or press Save to save the file.

A file can also be selected by double clicking on the file name in the file
list.
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Figure 50

The OpenDir
dialog.
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Selecting Directories

The OpenDir dialog lets you select a directory. It is similar to the
OpenFile dialog.

You must press the Select button to select a directory.

The Resource Manager uses the OpenDir dialog to select resource direc-
tories (see “The Resource Manager” on page 3-23).

Short Cuts

The OpenfFile, SaveFile and OpenDir dialogs provide some useful short
cuts, which can make life a lot easier.

The most useful short cut is file name completion. You enter only the first
few character of a file name, then type Tab, and the file name will be com-
pleted as much as possible.

Another useful feature is using “~” in path names. Typing “~” followed by
return takes you to your home directory. You can also type ~/subdir, to
refer to a subdirectory of your home directory. You can easily access
directories of other users, by typing ~username.




The System Properties

Figure 51

The System Prop-
erties stack.

Selecting SystemProps from the Tools pulldown in the system stack
shows the system properties stack. This stack lets you change system
properties.

Once you have changed the properties press Apply. To hide the window
press Done. Changes can be undone by pressing Reset.

When you press Apply, the values which you have entered are saved to
a file called .hyperlook in your stacks directory. This is a text file which
contains some frequently used variables which need saving between ses-
sions.

Changing the System Fonts

The system font list lets you specify which fonts you want to use in
menus, pulldowns and selectors. You can change the default list and add
fonts that you use most frequently.

When you press Apply, undefined fonts are removed from the list. A sin-
gle “~” character separates groups of fonts.
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Figure 52

The PrinterQueue
stack.

Using Hyperiook

Specifying a Printer

The default printer command used by tools such as the graphics editor
is “1pr -P1lw”". The lpr program prints a file to the printer named by the
-P option (see the UNIX documentation for the lpr command) L

You can change printers by giving the lpr command a different printer
name. For example: “1pr -Pnewsprint”. Ask your system administrator
to find out which printers you can use.

Changing the printer to “pageview -" lets you preview the generated
output using the pageview PostScript previewer. You can print the file
from the previewer.

You can examine the printer queue with the PrinterQueue stack which
is opened from the Tools pulldown in the system stack. Enter the name
of your printer at the top and press Refresh.

atandard input 338 bytes
£inger.ps 338 byres
Soseina i e e
189 standard input i ; 75946 bytes

Scrolling Parameters

The System properties stack lets you select the scrolling threshold and
scrolling delay times. These affect the speed at which text, scrolling lists
and fields scroll.

The Scroll threshold is the initial delay in milliseconds between
pressing the mouse down and the moment scrolling starts.

1. It must be a PostScript printer.
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The Scroll delay is the time between the scrolling of each line of text.
This affects the scrolling speed.

Logging Messages

HyperLook uses messages to pass information around in the system.
You can switch logging on to monitor these messages. See Chapter 7,
“Scripting” for more information on message passing. If you don't intend
to do any scripting, you don’t need to worry about logging messages.

Message logging means that messages are printed to the console as they
occur. This lets you analyze the message traffic of your application. Here
are examples of some messages:

from [?] to Stack(system) ——> StackOnLeft ()

from Stack (system) to Button(#2) —--> OnMouse ()
from Button (#2) to Button (#2) --> Action(0)

from Button (#2) to Stack (OpenStack) —--> InitStack()

Before switching logging on, make sure that you have opened a console
window. If you haven’t, messages will be printed all over the screen.

Report Errors

If you are writing your own scripts, you may find that errors are dis-
played when they occur. When an error occurs the error message is
displayed in the PostScriptError stack.
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It is sometimes useful to disable this feature, especially when an error
occurs frequently, or when your error causes more errors. Click on the
check box in the system properties stack to turn error reporting off.

Figure 53 7 /%Z;,fo%//////////%//;///;/
The o
PostScriptError

stack.

“?larray exec cont’
30 tadd, Tadd!
307 array exec cont! {fx :
rray exec cont’ (feoux! Srexec!}

AR

R

You can also switch error reporting off from the PostScriptError stack.
Use the checkbox in the lower left corner. See Chapter 7, “Scripting” for
more information on the PostScriptError stack.
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The OpenWindows Function Keys

Sun keyboards have some labelled function keys which have a function
defined by OpenWindows. The HyperLook functionality for these func-
tion Kkeys is the same as, or similar to the OpenWindows functionality:

Again
Redraw the stack (see “Redrawing Stacks” on page 3-12).

Front
Bring a stack to the front (see “Bringing Stacks to the Front” on
page 3-10). or send it to the back if it’s already in front.

Open
Iconify a stack (see “Iconifying Stacks” on page 3-11), or open it if
it is already an icon.

Undo

Undo the last operation in the graphics editor (see “Using the Clip-
board” on page 4-22).

Copy, Paste, Cut
Clipboard editing operations (see “The Clipboard” on page 3-18).

Help
Show help (see “Using Help” on page 3-3).

Home, End, PgUp, PgDn
Move to the first, last, previous or next card of the stack (see “Mov-
ing Between Cards of a Stack” on page 3-8).
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The Stack Menu

All of the operations that are available on the stack menu are described
in other parts of the manual. Here is a complete list of references to the
relevant sections.

Look

Home
Go to the home card. See “The Home Card” on page 3-7.

Next

Previous
Go to the next or previous card. See “Moving Between Cards of a
Stack” on page 3-8.

Refresh
Redraw the stack. See “Redrawing Stacks” on page 3-12.

Front/Back
Send the stack to the front or to the back. See “Bringing Stacks to
the Front” on page 3-10.

Close
Iconify the stack. See “Iconifying Stacks” on page 3-11

Zap
Zap the stack from the screen. See “Zapping Stacks” on page 3-12.

Edit
Cut
Copy

Paste

Clear
Clipboard editing operations. See “The System Properties” on
page 3-31.
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The Stack Menu

Copy Stack as Drawing
Copy a stack to the clipboard as a drawing. See “Copy as Drawing”
on page 5-23.

Select All

Select Up

Select Down

Select Left

Select Right

Move the cursor. See “Editing Text” on page 3-14.

Edit Mode

Switch to edit mode. See Chapter 5, “Editing Stacks”. This changes
the stack menus to include editing features (see “Edit Mode Menus”
on page 5-36). To get back to browse mode, select Browse Mode
from the Edit menu,

3-37



3-38

Using Hyperiook



555, S,
5555 g




HyperLook Graphics Editing

Figure 54

A PostScript
Graphics editor
object.

4-2

HyperLook provides a powerful graphics editor which is fully integrated
into the HyperLook system. The HyperLook graphics editor is useful
because it's just an object like a button or a slider. This makes it very
easy to add graphics editing capabilities to your own applications.

The editor is implemented using a graphics editor object called a
DrawTool. The functions described in this section therefore apply to all
the DrawTool objects in the system, even those in your own applications.

The editor is an Object Oriented PostScript Graphics Editor. This means
that it edits objects such as rectangles, ovals, lines, and images. This
type of editor is particularly useful for creating diagrams and technical
drawings.

The fact that the editor uses PostScript graphics means that drawings
produced with this tool can be scaled and rotated, and produce very high
quality output when printed on a PostScript device.




Figure 55

A drawing created
using the graphics
editor.

PostScript is a high level graphical programming language. It is also a
standardized page description language. It can produce high quality out-

put on a large range of devices.

"//_

Using PostScript makes your diagrams very portable. Lots of other appli-
cations and printing devices accept PostScript. Most of the diagrams in
this manual were produced with the graphics editor and then imported

into FrameMaker.
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Getting Started

Figure 56

The graphics edi-
tor stack.

Figure 57

The hyperdraw
program icon and
the drawing file
icon.

The editor is started by pressing the Draw button on the system stack.
This will show a HyperDraw stack. Pressing the button again creates
another instance of the stack.

When working with more than one drawing, it is sometimes useful to
have several editors active. Drawings or parts of drawings can be copied
and pasted between editors.

hypedraw exam pe.draw

Another way to start the editor is double clicking the hyperdraw program
icon in the Sun desktop file manager (see “Using the File Manager” on
page 2-9 to see how to install the icons in the file manager). If you want
to edit a drawing file, double click the drawing file icon.

You can get rid of the editor when you are finished by selecting zap from
the stack menu (see “Zapping Stacks” on page 3-12).




Figure 58
The tool pallet.

 Getting Started

The Tool Pallet

Figure 56 on page 4-4 shows the graphics editor stack. On the left hand
side it has a tool pallet which lets you choose drawing tool, colors, fill and
line styles. The bottom right corner displays the current magnification.

' | <«— pointer/text

— drawing tools

-¢— line/fill color

<&— line width/style

The scrollbars let you move your drawing around in the central portion
of the stack, which is called the paper. The stack can be resized using the
resize corners (“Resizing Stacks” on page 3-11).

Holding down the right mouse button on the paper shows a popup menu.
It has a number of submenus which give you access to the features of
the tool. In the following sections you will read instructions like “select
Open from the File menu”. This means “select the Open option from the
File sub menu of the popup menu”.

If you want an at-a-glance guide to the graphics editor menu functions
you should read “The Graphics Editor Menus” on page 4-34. Otherwise
read on and you will be taken on a tour of the graphics editor.
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Figure 59

After loading
example.draw.

4-6
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Loading Drawings

Select Open from the File menu to open a drawing. In the example in
Figure 59, the drawing draw/example.draw was loaded from the
HyperLook directory. See “Opening Files” on page 3-28 on how to use the
OpenFile dialog. Note that drawing files always have a “. draw” file name
extension.

Saving Drawings

To save a drawing select Save As. .. from the File menu. You can enter
a file name using the SaveFile dialog (See “Saving Files” on page 3-29).

Drawings can also be saved in the file from which they were originally
loaded. Use Save from the File menu to save the drawing in the file from
which it was loaded.

You can also save the drawing as Encapsulated PostScript. Select Save
EPS.. from the File menu to save the drawing in this format. See also
“Encapsulated PostScript Objects” on page 4-30.

-




Getting Started

Saving a drawing as EPS is useful if you want to import the drawing into
another application. Many word processing applications can import
Encapsulated PostScript graphics into their documents.

Printing Drawings

A drawing is printed by selecting Print from the File menu. A popup
message will appear to show that the drawing is queued for printing. See
“Specifying a Printer” on page 3-32 for how to specify the printer on
which the drawing is printed.

You can also use the drawps program to prepare a drawing for printing
on a PostScript printer. It converts a drawing into PostScript format. The
program can also be used to generated Encapsulated PostScript.

To print a drawing from a shell use!:

drawps < example.draw | lpr

1. Use the -P option of the Ipr command to specify a printer if necessary.
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Figure 60

Zooming out will
show the edges of
the paper.
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Zooming

After loading a drawing you can view it at different magnifications. To
zoom out (make the drawing appear smaller) select Zoom Out from the
View menu.

magnification

The magnification is displayed in the bottom right hand corner.

As you zoom out a few times, you will start to see the edges of the paper.
The paper edges indicate how the drawing fits on the paper when it is
printed.

You can zoom back in using the Zoom In option of the View menu. The
magnification can be varied from 12.5% to 800%.

At any time it is possible to zoom back to the default (100%) magnifica-
tion by selecting Zoom Normal from the View menu.

Moving Around

The position of the view can be changed using the scrollbars to the right
and below the paper. See “Using Scrollbars” on page 3-14 if you're not
sure how to use the scrollbars.




Figure 61

The circle is
selected.

A very useful way to change the position of the view is by holding the
Shift key down while dragging the left mouse button. This lets you drag
the view around.

Selecting Objects

Most drawing operations apply to the currently selected objects. Objects
can be selected by moving the mouse over them and clicking the left
mouse button. The fact that an object is selected is shown by its marker
points, usually at the four corners.

When selecting objects, make sure that the pointer is selected in the tool
pallet.

marker
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Figure 62

The circle and the
rounded corner
rectangle are
selected.
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You can also select more than one object at the same time. Hold the
mouse down somewhere outside the desired objects and drag a rectangle
around them. The objects inside the rectangle are selected

To extend the number of objects which are selected, use the middle
mouse button. This will add to the current selection, without deselecting
objects.

The middle mouse button can also be used to remove objects from the
current selection. Simply use the middle mouse button to click on a
selected object, or, with the middle button, drag a box around some
selected objects to remove them from the selection.

You have two options when you want to select an object which is behind
another object. Either enclose the obscured object by dragging a box
around it, or click more than once on the object. Each click will select the
object behind the currently selected one.

To select all objects in the drawing choose Select All from the Edit
menu.
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Figure 63

Adding a rectan-
gle.

Now you know how to view objects and how to select objects, we will
move on to editing objects. Most objects are created and edited in the
same way. In order to illustrate the creation and editing of objects we will
consider the editing of a rectangle in detail. The methods illustrated can
be applied to other object types in the same way.

Creating Objects

Let's start by drawing a new rectangle. First clear the view by selecting
all the objects and either pressing the Delete key or selecting Clear
from the Edit menu.

The rectangle tool is displayed in the panel on the left. When you click on
it will be highlighted, just like in the picture, to indicate that the next
thing that you draw will be a rectangle.

To create a rectangle, simply hold down the mouse at the desired location
on the paper, and drag until the rectangle is the correct size. When you
release the mouse button, the rectangle will be added.

After the rectangle is added the tool is switched back to the pointer auto-
matically.
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Creating Multiple Objects

If you double click in the tool pallet, the selected tool will be displayed in
gray instead of black. This means that the tool will not switch back to the
pointer when the object is created. Instead it will stay active until you
explicitly click on the pointer. This is useful when you want to add sev-
eral objects in a sequence.

Figure 64 A
Creating a single
rectangle (left) and
creating multiple

rectangles (right).
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Polygons have a special behavior when the multiple object feature is

enabled. See “Polygon and Spline Objects” on page 4-26 for more infor-
mation.
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Moving Objects

The rectangle is moved by holding down the mouse in the area of the

object when it is selected, and dragging the object to the desired location.
Figure 65

Moving an object
to a new location.

When more than one object is selected, all are moved accordingly.

Changing the Size of Objects

Objects can be edited using their markers. You can change the size of an
object by holding the mouse down in a marker, and dragging it until the
object has the required size.

Figure 66 i
of an object. o ¥
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Figure 67

Changing the size
of an object.

4-14

Graphics Editing

The width and height of the object (in pixels) is displayed near the cursor
when you are resizing it.

Another way to scale objects is to select Scale 50% or Scale 200% from
the Special menu. This is an easy way to make the selected objects
twice or half their size. See also “Constrained Editing” on page 4-15 on
how to change the size of an object without changing its width/height
ratio.

Rotating Objects

To rotate an object (or a group of objects), hold the mouse button down
in a marker point while holding down the Meta key.

While the mouse is down you are able to rotate the object around the
selected point. When the button is released, the object is displayed in its
new orientation.

The degrees of rotation are displayed near the cursor while you are rota-
tion the object.

To undo the rotation, select Flip to normal from the Special menu.




- | Editing Objects

Constrained Editing

While editing objects, it is possible to apply a constraint. Hold down the
Control key while dragging an object. It will only move vertically or hor-
izontally.

Similarly, holding down the Control key while stretching the corner of
an object will restrict its shape to a square or a circle, or it will maintain
the image’s original width/height ratio.

Rotating an object while holding down the Control key will restrict the
angle of rotation to multiples of 45 degrees.

Using the Grid

You will notice that all editing operations are constrained to a grid. The
size of the grid can be changed from the Grid menu.

The default grid size is 8, but smaller and larger sizes can be selected.
Grid alignment can be switched off by selecting None from the Grid
menu.

The grid lines are usually displayed in the background of a drawing. They
are spaced according to the grid size and the current magnification. If the
grid is small, not all grid lines are displayed.

Drawings created using a particular grid size should be edited using that
same size or a smaller one. Otherwise, if the grid size is too large, it will
be hard to edit the drawing without realigning objects to the new grid.
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Aligning Objects

It is sometimes useful to align objects so that certain edges are on the

same line.

Figure 68

Aligning some

objects to their

right edge.
The Align menu provides several options. The top, left, right, or bottom
edge can be aligned. Also, objects can be aligned by their center point,
either at one point, along a vertical or horizontal line, or to the grid.
Alignment is always relative to the back most object. This object is not
moved, the other objects are aligned to it.
Aligning the center of objects is useful when you want to put a text string
in the center of a bounding box.

Figure 69 0 0 0 A . .

Centering a text P . & .

string in a box. N . " = [ ]
| Jihe label The label
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Figure 70

Selecting a fill
color.

Figure 71

Changing the
color of a rectan-

gle.

~ Editing Objects

Selecting the Fill and Line Color

Objects are created using the current colors specified in the tool pallet.
You can change the fill color of the selected objects by selecting a new
color.

transparent current color

When you hold down the mouse on the fill color tool (on the right), a pal-
let of colors is shown. You can point the mouse at the appropriate color.
When you release the mouse over a color, it will be applied to the selected
objects. See also “Color Selectors” on page 3-17.

The first color in the pallet (in the top left corner) is transparent. If this
color is chosen, the object is not filled (objects behind it will be visible).

The line color is chosen in the same way, using the line color tool (on the
left). A transparent line color means no line at all!.

1. It is possible to give an object a transparent fill color and a transparent line color. It will be invisible!
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Selecting the Line Width

When you hold down the mouse in the line width tool, a panel pops up,
from which you can select a new line width.

Figure 72 by
Selecting the line e
width. e
| . current line width
o
=
I
|

This applies to the selected objects and all new objects that you create.
The figure below shows rectangles with different line widths.

Figure 73

Changing the line
width of the rect-
angle.
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Figure 74

Selecting arrow
heads.

Figure 75

Some lines and
arcs with arrow
heads.

Selecting Arrowheads

Lines and arcs can have arrowheads. To try this out, you must first cre-
ate a line. Then select an arrowhead style with the arrowhead tool.

current arrowhead style

- —

The arrowhead style applies to the éeiected lines and curves. Only arcs
and lines can have arrowheads. The size of the arrowhead depends on
the line width of the line or arc.
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Figure 76

Bringing an object
to the front.

Figure 77

Grouping two
objects together.
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Front to Back Order

As you create objects, you will notice that they can overlap. If you want
to bring an object to the front, select Front from the Arrange menu.

Alternatively you can select Back from the Arrange menu to send the
selected object to the back.

Grouping

It is sometimes useful to treat a set of objects as a single object. This is
achieved by grouping. Select several objects, and choose Group from the
Arrange menu. You will see that the markers for the individual objects
are replaced by markers for the entire group. The bounding box of the
group is just large enough to enclose all the grouped objects.




